用idea导入了新项目之后,启动报错,用eclipse的启动没有报错。
无意中,发现一句nopermisson exception,在bind1099端口的时候,于是查看idea中的tomcat配置,果然:
Intellij启动Tomcat的时候,会启动1099作为JMX端口。所以如果同时启动多个Tomcat实例,这个端口是会冲突的。
改成1098之后,启动成功。
用idea导入了新项目之后,启动报错,用eclipse的启动没有报错。无意中,发现一句nopermisson exception,在bind1099端口的时候,于是查看idea中的tomcat配置,果然:Intellij启动Tomcat的时候,会启动1099作为JMX端口。所以如果同时启动多个Tomcat实例,这个端口是会冲突的。改成1098之后,启动成功。
刚才使用Tomcat启动web项目的时候,发现出现了错误
问题提示:Error running ‘Tomcat 9’: Address localhost:
1099
is already in use
问题分析:Tomcat9 运行错误,本机地址
1099
端口
号已经被占用。
方法解决:根据分析,我们需要判断我们
端口
号是不是正在有其他进程在占用
分两种情况:
情况一:CMD控制台能找到该
端口
号进程,对应第一种解决方案。
因为我们
端口
号的确被占用
情况二:CMD控制台找不到该
1、打开cmd窗口,以管理员身份运行
2、输入命令:netstat -aon|findstr
1099
(8080)(此处为被占用的
端口
号),然后 我们可以看到
1099
(8080)
端口
被方框中标注的地方占用
3.显示
1099
端口
被52296占用,直接kill就可以
再次输入命令:taskkill -f -pid 52296
接下来再去重新启动应用程序,程序便可以正常启动了。
今天我启动在
IDEA
上启动tomcat的时候,报出如下错误信息:
错误: 代理抛出异常错误: java.rmi.server.ExportException: Port already in use:
1099
; nested exception is:
java.net.BindException: Address already in use: JVM_Bind
1099
端口
是干啥的?为啥会报错?这就引起了我的好奇,对这个
1099
端口
相关探究了一波,以下是简略过程。
首先,追根溯源,是启动tomcat
JMX(Java Management Extensions)是一个为应用程序提供管理功能的框架。也就是应用程序暴露一个
端口
,可以通过这个
端口
,查看程序的状态,修改程序的配置。
网上关于程序员四个层次,很形象说明JMX的功能。
程序新手,配置是写死在程序中,修要修改时就去改代码,然后重新编译发布。
程序熟手,配置在文件中(JAVA一般都是properties文件),修要修改时就去修改配置文件,但还是必须重启系统,以便读取配置文件里最新的值。
程序好手,则会写一段代码,把配置值缓存起来,系统在获取的.
IDEA
中启动Tomcat服务器时JMX port
1099
被占用
错误提示:
错误: 代理抛出异常错误: java.rmi.server.ExportException: Port already in use:
1099
; nested exception is: java.net.BindException: Address already in use: JVM_Bind
也就是
1099
...